Tuesday, August 14, 2012

Required OS Packages for EBS R12 on Oracle Linux 6 and Red Hat Enterprise Linux 6

Hi All

Here the list for Required OS Packages ( rpm's ) for EBS R12 on Oracle Linux 6 and Red  Hat Enterprise Linux 6.

Pay attention:  Only the latest version of EBS 12.1.3 with Database 11.2.0.3 can be installed there  (see the Oracle certifications for more details).


*** You can also use the following note to install the needed RPM's

EBS R12 Pre-Install RPM Available for Oracle Linux 5 and 6


GA (6.0) or higher of Oracle Linux 6 is required
GA (6.0) or higher of Red Hat Enterprise Linux (RHEL) 6 is required
The following packages (or versions of packages) are not part of the OS distribution media and must be downloaded separately (from http://oss.oracle.com/projects/compat-oracle/files/Enterprise_Linux/) for both Oracle Linux 6 and RHEL 6 and installed manually:
  • openmotif21-2.1.30-11.EL6.i686 (32-bit)1
  • xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386 (32-bit)
The following packages must be installed from the Oracle Linux 6 or RHEL 6 distribution media:
  • binutils-2.20.51.0.2-5.11
  • gcc-4.4.4-13.el16.x86_64
  • gcc-c++-4.4.4-13.el16.x86_64
  • glibc-2.12-1.7.el6.i686 (32-bit)
  • glibc-2.12-1.7.el6.x86_64
  • glibc-common-2.12-1.7.el6.x86_64
  • glibc-devel-2.12-1.7.el6.i686 (32-bit)
  • glibc-devel-2.12-1.7.el6.x86_64
  • libgcc-4.4.4-13.el6.i686
  • libgcc-4.4.4-13.el6.x86_64
  • libstdc++-devel-4.4.4-13.el6.i686
  • libstdc++-devel-4.4.4-13.el6.x86_64
  • libstdc++-4.4.4-13.el6.i686
  • libstdc++-4.4.4-13.el6.x86_64
  • make-3.81-19.el6.x86_64
  • gdbm-1.8.0-36.el6.i686
  • gdbm-1.8.0-36.el6.x86_64
  • libXp-1.0.0-15.1.el6.i686
  • libXp-1.0.0-15.1.el6.x86_64
  • libaio-0.3.107-10.el6.i686
  • libaio-0.3.107-10.el6.x86_64
  • libgomp-4.4.4-13.el6.x86_64
  • sysstat-9.0.4-11.el6.x86_64
  • util-linux-ng-2.17.2-6.el6.x86_64
  • unzip-5.52-3.0.1.el5.x86_642
  • compat-libstdc++-296-2.96-144.el6.i686
  • compat-libstdc++33-3.2.3-69.el6.i686
Additionally, the following RPMs are required for the database tier running 11gR2 (users must upgrade the bundled 11gR1 DB to 11gR2 either before or after installing 12.1) on the database tier:
  • compat-libstdc++-33-3.2.3-69.el6.x86_64
  • elfutils-libelf-devel-0.148.1-el6.x86_64
  • kernel-uek-headers-2.6.32-100.28.5.el6.x86_64
  • libaio-devel-0.3.107-10.el6.x86_64
  • unixODBC-2.2.14-11.el6.i686
  • unixODBC-devel-2.2.14-11.el6.i686
  • unixODBC-2.2.14-11.el6.x86_64
  • unixODBC-devel-2.2.14-11.el6.x86_64
  • xorg-x11-utils-7.4-8
Note:
1: The openmotif package version must be 2.1.30 (for example, openmotif-2.3.3-1 is not supported).
2: This unzip package (available from EL 5 distribution) is only required for purposes of running Rapid Install to unzip the required EBS files as part of the installation and should be reverted after the install of EBS. Alternatively, users can backup the existing unzip 6.0 in /usr/bin, copy the unzip 5.5 from the EBS staging directory to /usr/bin for purposes of installing EBS, and then restore the unzip 6.0 when done.

Good Luck ... 

39 comments:

  1. I have been recently installing an R12 vision instance. The default libraries that install with Redhat 6.3, are newer than most of these, even with a bare bones OS install. Downgrading is very difficult as even YUM relies on some of them... You need more than luck.

    ReplyDelete
  2. Stephen.
    We installed the OEL6.2 + all rpm's and migrated the Upgraded R12 instance from RH5. It's works just perfect. Fast and Furious :-)

    ReplyDelete
  3. So the 6.2 releases are at the older packages level?

    ReplyDelete
  4. Yes. And this is not RH6 , this is Oracle Enterprise Linux.
    Also, during the OEL 6 installation we checked all developers and gcc options. It helped as to solve some issues with rpm's

    ReplyDelete
  5. I am curious, i am back working on this again, and I find that running redhat 6.3, all of the glibc libraries are much newer. I have gone through and downgraded them all to the appropriate levels. Now when trying to add the i686 require packages for glibc, I get errors related to needing older NSS packages. And when downgrading those packages, I get more packages that need downgrading. I can't be the only one who has had these issues. Any ideas what am I doing wrong?

    ReplyDelete
  6. HI Stephen, do not downgrade it. Use your versions. The RPM's packages can be with bigger version.
    There are only 2 required versions:
    openmotif21-2.1.30-11.EL6.i686 (32-bit)
    xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386 (32-bit)

    ReplyDelete
  7. I was able to get this all to work on Redhat 6.0. I tried redhat 6.3, 6.2 OEL 6.2 and even some Redhat 5's. It all came down to packages not being new enough, or to new. And my first install was with RHEL 6.3, where i was able to get a vision 12.1.1 instance up and running. However when moving forward to path up to 12.1.3, i had a host of issues. The support guys on the OTN forums always pointed at the package versions of the GLIBC and GCC etc. I now have the OS prepared with all the appropriately mentioned packages in the document. I will try to remember to follow up once 12.1.3 is running.

    ReplyDelete
  8. Hi Stephen,
    You can contact me for any issues. Will be happy to help you.

    ReplyDelete
  9. GA (6.0) or higher of Oracle Linux 6 is required
    can you explain what is the abbreviation "GA"

    ReplyDelete
  10. Arty,

    Your list has the same typos as in "Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.2) for Linux x86-64 (Doc ID 1330701.1)" :

    1. compat-libstdc++33-3.2.3-69.el6.i686 should be
    compat-libstdc++-33-3.2.3-69.el6.i686 (minus after ++)

    2. gcc-c++-4.4.5-6.el16.x86_64 should be gcc-c++-4.4.5-6.el6.x86_64
    (el6 instead of el16)


    There are more issues with installing the 32b libs after the 64b ones are already installed, including disagreements btw yum and rpm. But happy to hear you had a smooth experience!

    ReplyDelete
  11. Please, help to solve issue with error RW-50004 and RW-50010. I am stuck on it. It arises in the begining of installation of OEBS 12.2.0. I have checked everything twice. All kernel and network parameters and zip-files are correct. Md5sum is matched. So i can not understand where is a problem. What am doing wrong?

    ReplyDelete
    Replies
    1. Privet Kostia.. Posmotri /var/log/messages. Tam niaverniaka budut oshibki.Pishi esle chto....

      Delete
  12. Hi, will it be enough unzip-5.52-3.el5.x86_64.rpm for satisfying point 2? "This unzip package (available from EL 5 distribution)" As i can not find anywhere a package unzip-5.52-3.0.1.el5.x86_64.rpm which is mentioned almost in the all ebs guides. I think it was caused by the copy-pasting from mistakable source.

    ReplyDelete
    Replies
    1. I think yes. According the oracle document :
      "Alternatively, users can backup the existing unzip 6.0 in /usr/bin, copy the unzip 5.5 from the EBS staging directory to /usr/bin for purposes of installing EBS, and then restore the unzip 6.0 when done."

      Delete
  13. This comment has been removed by the author.

    ReplyDelete
  14. I have found unzip file as was described above in stage folder and copied it in /usr/bin instead of original one which i have installed before. But when i started to create stage area i have noticed something strange: all files were unziped not in their name order.

    Please enter the directory containing the zipped installation media:
    /ZIP
    Unzipping V35231-01_5of5.zip
    Unzipping V37515-01_2of6.zip
    Unzipping V35804-01_2of2.zip
    Unzipping V37515-01_1of6.zip
    Unzipping V35806-01_1of3.zip
    Unzipping V35230-01_1of2.zip
    Unzipping V35809-01.zip
    Unzipping V29764-01.zip
    Unzipping V35807-01.zip
    Unzipping V35803-01_2of3.zip
    Unzipping V35803-01_1of3.zip
    Unzipping V29856-01.zip
    Unzipping V35803-01_3of3.zip
    Unzipping V35805-01_2of2.zip
    ...
    Is it normal? Could it cause crash of EBS install??

    ReplyDelete
  15. Done Copying additional patches

    Verifying stage area...

    Directory //StageR12/TechInstallMedia is valid
    Directory //StageR12/TechPatches/DB is valid
    Directory //StageR12/TechPatches/MiddleTier is valid
    Directory //StageR12/EBSInstallMedia/AppDB is valid
    Directory //StageR12/EBSInstallMedia/Apps is valid
    Directory //StageR12/EBSInstallMedia/AS10.1.2 is valid
    Directory //StageR12/TechInstallMedia/database is valid
    Directory //StageR12/TechInstallMedia/ohs11116 is valid
    Directory //StageR12/TechInstallMedia/wls1036_generic is valid


    Stage area verified.

    Press enter to continue...

    ReplyDelete
  16. No, i even can not to start rapidwiz install. it is crashing in the begining. ) Before that (previous try to install ebs) i at lest could to start rapidwiz and get error 5004)
    I am using RED HAT 6.3 and this guide. http://appsdbaworkshop.blogspot.com/2013/10/oracle-applications-r122-installation.html But nothing helps. This is my 2-d try. %) 1-st try was on CentOS 6.3. The next i suppose will be on Oracle 6.4

    ReplyDelete
  17. This comment has been removed by the author.

    ReplyDelete
  18. Problem was solved by returning kenrel parmeters ans security option to default value.
    But now i have error:

    [root@node1 rapidwiz]# Exception in thread "main" java.lang.UnsatisfiedLinkError: /StageR12/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at sun.security.action.LoadLibraryAction.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)
    at sun.awt.DebugHelper.(Unknown Source)
    at java.awt.Component.(Unknown Source)
    Could not find the main class: oracle.apps.ad.rapidwiz.RIWizard. Program will exit.

    ReplyDelete
  19. have managed to solve by:
    yum install libXtst.so.6 --nogpg

    ReplyDelete
  20. after starting rapidwiz and preparation checks process failed at 0 % with error (like in previous time):

    Fatal Error: TXK Install Service

    oracle.apps.fnd.txk.config.ProcessStateException: OPatch process failed : Exit=1 See log for details. CMD= /d01/oracle/PROD/11.2.0/OPatch/opatch napply -skip_subset -skip_duplicate -verbose -silent -ocmrf /d01/oracle/PROD/11.2.0/temp/PROD_node1/DBInstallHome/fnd/admin/template/txkForms_ocm.rsp /d01/oracle/PROD/11.2.0/temp/PROD_node1/patches/16342486/16342486/

    at oracle.apps.fnd.txk.config.OPatchActionNode.processState(OPatchActionNode.java:296)

    at oracle.apps.fnd.txk.config.PatchActionNode.processState(PatchActionNode.java:187)

    at oracle.apps.fnd.txk.config.PatchNode.processState(PatchNode.java:338)

    at oracle.apps.fnd.txk.config.PatchesNode.processState(PatchesNode.java:79)

    at oracle.apps.fnd.txk.config.InstallNode.processState(InstallNode.java:68)

    at oracle.apps.fnd.txk.config.TXKTopology.traverse(TXKTopology.java:594)

    at oracle.apps.fnd.txk.config.InstallService.doInvoke(InstallService.java:224)

    at oracle.apps.fnd.txk.config.InstallService.invoke(InstallService.java:237)

    at oracle.apps.fnd.txk.config.InstallService.main(InstallService.java:291)



    Cannot install Oracle Database Home patches

    RW-50010: Error: - script has returned an error: 1
    RW-50004: Error code received when running external process. Check log file for details.
    Running Database Install Driver for PROD instance

    ReplyDelete
  21. Replies
    1. Hi Kostia,
      Please use this link to check the server before installation of EBS and DB.
      It will show you what is missing.
      http://dba-story.blogspot.co.il/2012/03/prepare-operating-systems-requirements.html

      Delete
  22. This comment has been removed by the author.

    ReplyDelete
  23. Thank you, but i am trying to install OEBS 12.2.0. Your link is designed for 12.1.1. Could i use it for 12.2.0 release?

    ReplyDelete
    Replies
    1. Kostya, please run the rda for db 11.2.0 check. Also review the /var/log/messages for any error. If you still need my help, please send me your email via contact me form on my blog.

      Delete
  24. i have sent you my e-mail via Linked In as i could not do it via your blog. i am sorry. And i will try to do this "please run the rda for db 11.2.0 check. Also review the /var/log/messages for any error" and will update this topic asap. Thank you.

    ReplyDelete
  25. "No, you cannot download RDA other than metalink. And for metalink you must have a valid CSI. https://forums.oracle.com/thread/1120075"

    ReplyDelete
  26. But i am not DBA and i have no access to metalink. So only one i can provide - logs.

    ReplyDelete
  27. This comment has been removed by the author.

    ReplyDelete
  28. [root@node1 ~]# cat /var/log/messages
    Dec 9 12:47:49 node1 NetworkManager[1891]: domain name 'localdomain'
    Dec 9 13:00:52 node1 dhclient[1916]: DHCPREQUEST on eth0 to 192.168.198.254 port 67 (xid=0x4ae71704)
    Dec 9 13:00:52 node1 dhclient[1916]: DHCPACK from 192.168.198.254 (xid=0x4ae71704)
    Dec 9 13:00:52 node1 NetworkManager[1891]: (eth0): DHCPv4 state changed renew -> renew
    Dec 9 13:00:52 node1 NetworkManager[1891]: address 192.168.198.128
    Dec 9 13:00:52 node1 NetworkManager[1891]: prefix 24 (255.255.255.0)
    Dec 9 13:00:52 node1 NetworkManager[1891]: gateway 192.168.198.2
    Dec 9 13:00:52 node1 NetworkManager[1891]: nameserver '192.168.198.2'
    Dec 9 13:00:52 node1 NetworkManager[1891]: domain name 'localdomain'
    Dec 9 13:00:52 node1 dhclient[1916]: bound to 192.168.198.128 -- renewal in 834 seconds.
    Dec 9 13:14:46 node1 dhclient[1916]: DHCPREQUEST on eth0 to 192.168.198.254 port 67 (xid=0x4ae71704)
    Dec 9 13:14:46 node1 dhclient[1916]: DHCPACK from 192.168.198.254 (xid=0x4ae71704)
    Dec 9 13:14:46 node1 dhclient[1916]: bound to 192.168.198.128 -- renewal in 801 seconds.
    Dec 9 13:14:46 node1 NetworkManager[1891]: (eth0): DHCPv4 state changed renew -> renew
    Dec 9 13:14:46 node1 NetworkManager[1891]: address 192.168.198.128
    Dec 9 13:14:46 node1 NetworkManager[1891]: prefix 24 (255.255.255.0)
    Dec 9 13:14:46 node1 NetworkManager[1891]: gateway 192.168.198.2
    Dec 9 13:14:46 node1 NetworkManager[1891]: nameserver '192.168.198.2'
    Dec 9 13:14:46 node1 NetworkManager[1891]: domain name 'localdomain'
    Dec 9 13:28:07 node1 dhclient[1916]: DHCPREQUEST on eth0 to 192.168.198.254 port 67 (xid=0x4ae71704)
    Dec 9 13:28:07 node1 dhclient[1916]: DHCPACK from 192.168.198.254 (xid=0x4ae71704)
    Dec 9 13:28:07 node1 dhclient[1916]: bound to 192.168.198.128 -- renewal in 865 seconds.
    Dec 9 13:28:07 node1 NetworkManager[1891]: (eth0): DHCPv4 state changed renew -> renew
    Dec 9 13:28:07 node1 NetworkManager[1891]: address 192.168.198.128
    Dec 9 13:28:07 node1 NetworkManager[1891]: prefix 24 (255.255.255.0)
    Dec 9 13:28:07 node1 NetworkManager[1891]: gateway 192.168.198.2
    Dec 9 13:28:07 node1 NetworkManager[1891]: nameserver '192.168.198.2'
    Dec 9 13:28:07 node1 NetworkManager[1891]: domain name 'localdomain'
    [root@node1 ~]#

    ReplyDelete
  29. If you want your ex-girlfriend or ex-boyfriend to come crawling back to you on their knees (even if they're dating somebody else now) you must watch this video
    right away...

    (VIDEO) Why your ex will NEVER come back...

    ReplyDelete